Error opening Vault file: Unable to read beyond the end of the stream.

Symptoms

When opening a Vault file, you see the following error message:

Error opening Vault file.

Unable to read beyond the end of the stream.

 

Causes

There are at least two causes for this error:

  1. You are using an older version of Password Vault to open the file than the version that was used to save the file. If you move this file between multiple computers, then this cause is likely.
  2. The file has been corrupted, possibly while it was being saved. Don't worry—Password Vault takes several steps to guard against data loss, so your file can probably be recovered.

 

Solution

Try the following solutions in order. Move on to the next step only if the previous steps did not solve your problem.

  1. Update Password Vault to the latest version. Under the Help menu, select Check for Updates.... Then try opening the file again.
  2. If you have made backups of your file, try opening several of the latest backups. If a backup opens successfully, then you can restore it by copying it to the folder where your original file is saved.
  3. Open Windows Explorer and navigate to the folder where your file is saved. Look for a file with the same name as your file but with a .bak extension. For example, if your file was named Passwords.pvf, then you would look for Passwords.bak. This .bak file is an automatic backup made by Password Vault when you save your file. If you see this file, then try opening it in Password Vault. If it opens successfully, then you can restore it by changing its extension back to .pvf.
  4. Windows Vista and Windows 7 only. Open Windows Explorer and navigate to the folder where your file is saved. Right-click the file and select Properties. Go to the Previous Versions tab. You should see a list of backups of your file that Windows has automatically saved. Select the latest version and click Restore.... Then try opening the file again in Password Vault. If it opens successfully, then you do not need to take any additional action.

If none of the above steps solved your problem, or if you didn't understand these instructions, you should contact Password Vault Support as soon as possible.